Autore Topic: Progetto T64 Media 64bit  (Letto 34445 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Progetto T64 Media 64bit
« il: Agosto 23, 2015, 03:37:25 pm »
T64 Media e T64 Light64bit beta.
Kernel 4.1.3-EmSee-x86_64
Dopo qualche tempo di studio circa i Puppy a 64 bit, partendo da una versione pre-alpha di Tahr64 6.0.2, ho sviluppato due distro, una "Fat" da 848,5 Mb e una "Light" da 645,4 Mb ma priva delle applicazioni di editing Audio/Video. Molte le correzioni all'originale che non permetteva l'utilizzo di programmi grafici per mancanza di librerie adatte a 64 bit ed anche l'implementazione di ffmpeg per le applicazioni multimediali. Nuovi programmi aggiunti audio/video che la rendono adatta all'editing professionale. È anche completa di applicazioni adatte all'uso ufficio/lavoro, di sviluppo Bash+Gtk e al P2P.
Portante di alcune applicazioni predefinite è LibreOffice.
È  un progetto aperto a tutti gli utenti, che possono inviare nuovi programmi a 64bit, risolvere bug e suggerire nuove idee.
Verifica e ricerca bug ben accolti.

Nuove versioni di T64 Mediia e T64 Light definitive e stabili.
Aggiornamenti e patch direttamente dal menu/impostazioni.

- Puppy_T64-Media_1.8 856,5 MB
https://drive.google.com/open?id=0B4QTpUg4_O2MazRHR3FtQ2xfTGc
MD5: 1b4ce98d3627a17f8ed6e1786a65db5c

- Puppy_T64-Light_1.8 645,5 MB
https://drive.google.com/open?id=0B4QTpUg4_O2MWWZoOHVwRE1WRUE
MD5: 5cc7e99248ae384ae9121e3d29002170

Langpack fix https://drive.google.com/open?id=0B4QTpUg4_O2MbUx3akxmTlhRVHM

Files extra:

- kernel: https://drive.google.com/open?id=0B4QTpUg4_O2MeThkOXZoSkgxY0E 107,7 Mb
- devx: https://drive.google.com/open?id=0B4QTpUg4_O2MWjI3aF9SRm02Vlk 117,9 Mb
- Compatibilità 32bit: https://drive.google.com/open?id=0B4QTpUg4_O2MRTVxVVZiWjFwYVE 104,7 Mb
- Wine64: https://drive.google.com/open?id=0B4QTpUg4_O2MazBkZHpQdHRHUHM (irfanView e VirtualDub incusi) 76,1 Mb





Added:
Right-click-april64-6.9.6
firefox-38.0.1esr-64bit
amule-adunanza_2.3.1_amd64
opera_12.16.1860_amd64
vivaldi-snapshot_1.0.178.2-1_amd64
pfilesearch-2.1
pfind-6.2
cinelerra-4.6-14.04.1-x86_64-static
wbar_2.3.0-1_amd64
doublecmd-0.6.2.gtk2.x86_64
FileZilla_3.10.0_amd64
hydrogen_0.9.6~beta3-1_amd64
LibreOffice_4.4.3.2_Linux_x86-64
lmms_1.0.0+bzr2569_amd64
ocenaudio-2.0.15
xpad-4.2-x86_64-1
XnViewMP-amd64
PuppyUnits-1.7
poedit_1.5.4_amd64
lxrandr-0.3.0-1-x86_64
flashplayer11-11.2.202.491
libgif7-5.1.1-1.2.x86_64
libjpeg9-9.1.0-11.4.x86_64
mtpaint-3.44.89-amd64
pmusic-4.6.4
ffmpeg-2014-12-19-amd64
firewallstate-2.5-x86_64.pet
frisbee-1.1-20130415.pet
guvcview_1.7.1-tahr64.pet
libstardust-150130.pet
momanager-20150829.pet
pequalizer-0.9.0-x86_64.pet
ppm_auto-1.9_0402.pet
PupClockset-2.3.1.pet
pse_search.pet
Pfile2PDF.pet
xsane-0.997-patched-x86_64.pet
edit_sfs-2.1.pet
netmon_wce-2.6-x86_64.pet
Find'n'Run

Fixed:
initrd
Cups
Open_With
Send_To
MIME-types
osmo
urxvtset
gfnrename
pctorrent
pccreatetorrent
xarchive
pburn
firewall
pdvdrsab
wag-profiles.sh
« Ultima modifica: Giugno 04, 2016, 07:56:05 am da xanad »
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #1 il: Agosto 29, 2015, 11:33:03 am »
Altro problema all'avvio di Firefox. Sempre con l'aggiornamento e le cartelle dei dati personali che si trovano in root/.mozzilla/firefox. Cancellando la cartella xxxxx. default e il file profiles.ini sembra funzionare ma poi ritorna il problema.
@Watchdog
hai qualche suggerimento?
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #2 il: Agosto 29, 2015, 09:30:20 pm »
Io veramente installo firefox 40.0 per amd64 a parte e in maniera classica usando i binari di mozilla e non uso il browser installato di default e a me firefox 40.0 funziona bene. Anzi sono riuscito a fare il firefox-portable-0.8.2_64 che usa lo stesso profilo di quello a 32 bit con un semplice link alla cartella inclusa .mozilla. Sto usando la versione originale di 666philb e ho cercato di farci funzionare skype senza riuscirci. Ma ho perso molto tempo e sono rientrato da poco. Ti prometto che appena ho tempo guardo la tua release che ho gia' scaricato. Tieni presente che firefox sta cambiando le API per le extensionsions abbandonando libxul nelle prossime release e sono stanco di aggiornare e stare dietro all'obsolescenza programmata. Firefox 40.0 (ora vedo che e' uscita la 40.0.3...) e una delle ultime versioni che riesco a fare funzionare anche con i vecchi puppy per cui penso che terro' disabilitati gli aggiornamenti rimanendo per qualche tempo con questa versione di firefox che uso in versione portable in /mnt/home in tutti i miei puppy. Forse devo aggiungere che faccio gli aggiornamenti di firefox in modo manuale scompattando il nuovo .tar.bz2 nella vecchia cartella: forse se lasci fare l'aggiornamento a firefox si comporta in modo diverso.
« Ultima modifica: Agosto 29, 2015, 09:45:52 pm da watchdog »

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #3 il: Agosto 30, 2015, 08:41:16 am »
Sto provando il tuo tahr-media-64 versione light. Il lancio di firefox browser in /mnt/home che nelle altre installazioni funziona mi presenta il seguente messaggio di errore (anche se si avvia e sembra funzionare):

Codice: [Seleziona]
An error occurred while loading or saving configuration information for firefox. Some of your configuration settings may not work properly.
Codice: [Seleziona]
Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details -  1: Could not send message to GConf daemon: Method "GetIOR" with signature "" on interface "org.gnome.GConf" doesn't exist
)

Con un chroot su un filesystem di tahr 6.03 32 bit riesco a lanciare skype da dentro tahr-64 col tuo nuovo kernel. Evviva! :D

EDIT: Googlando ho risolto l'errore di gconf di cui sopra all'apertura di firefox. Basta editare /usr/share/dbus-1/services/org.gnome.GConf.service col seguente contenuto:

Codice: [Seleziona]
[D-BUS Service]
Name=org.gnome.GConf
Exec=/usr/lib/libgconf2-4/gconfd-2
« Ultima modifica: Agosto 30, 2015, 09:10:07 am da watchdog »

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #4 il: Agosto 30, 2015, 10:25:26 am »
@watchdog
- Mitico! Firefox tornato ok, i loro continui aggiornamenti stanno snervando un po'....
Quello che mi sorprende è la richiesta di D-bus, teoricamente non necessaria, se non a system-d che prevede un rischio di sicurezza al pc. Debian si è scisso nel fork Devuan, con relativa fuga degli sviluppatori,  per questo problema.
- Il nuovo kernel (è pronta anche la versione 4.1.6) funziona alla grande. Ho risolto anche il lettore SD interno. È anche aumentata la velocità del sistema.
------
- light crypt sempre irrisolto. Stesso errore anche in Slacko64.
- patch in preparazione con tre nuove applicazioni utili.
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #5 il: Agosto 30, 2015, 12:10:48 pm »
- light crypt sempre irrisolto. Stesso errore anche in Slacko64.
- patch in preparazione con tre nuove applicazioni utili.

Non ho piu' provato il lightcrypt: uso l'heavy cripting. Nella patch includi la cupspatch dell'altro thread che non e' stata applicata (almeno nella versione light del tuo ultimo tahr64).
Manca il desktop file di osmo se non sono cecato...  :( Anzi c'e' ma devi cambiare la Categoria (Office non accettato). Io ho usato X-Calculate.
« Ultima modifica: Agosto 30, 2015, 03:59:46 pm da watchdog »

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #6 il: Agosto 31, 2015, 10:51:13 am »
Prima patch per Tahr Media e Tahr Light:
https://drive.google.com/file/d/0Bz9e78iH9qX7ZUFkbmZlazBRN1k/view?usp=sharing

Fix:
cups 1 e 2 - Watchdog
firefox - Watchdog
osmo - Watchdog
mtpaint
pulizia menu, file non pertinenti
right-click modificato

Nuovi programmi:
partview, versione differente ma molto più chiara e leggibile
ptheme, gestione del tema grafico globale
pse_search. programmino in htm creato per migliorare la ricerca nei siti italiano e internazionali

PSE_search


pTheme


partview
« Ultima modifica: Agosto 31, 2015, 10:53:50 am da xanad »
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #7 il: Agosto 31, 2015, 12:13:42 pm »
Ho personalizzato la tua Thar_Light-64-k_4.1.3-EmSee_x86-64 e ho paura di toccarla perche' mi soddisfa pienamente. Comunque ho scaricato la patch.

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #8 il: Settembre 01, 2015, 09:24:52 am »
Patch 02
https://drive.google.com/file/d/0Bz9e78iH9qX7Uk9vRTc4dGdRWTg/view?usp=sharing

fix pMusic e nuova versione 4,7
Radio streamer (pMusic)
Peasyscan scansione immagini
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #9 il: Settembre 01, 2015, 10:19:08 am »
La tua patch 01 corrompe la mia installazione della stampante brother laser hl2130: non stampa piu' e la stampante non e' piu' rilevata non so perche'. Sto mantenendo il savefile originale applicando le patch manualmente. Cosi' mi funziona tutto.

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #10 il: Settembre 01, 2015, 10:41:59 am »
Ho aggiunto i tuoi file come richiesto senza modifiche. Ma non capisco, installando non funziona ma copiando manualmente i file estratti dalla patch tutto funziona?
Non sono a casa per controllare, ma I tuoi pet hanno pinstall.sh all'interno?
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #11 il: Settembre 01, 2015, 11:36:53 am »
Non ho mai usato pinstall.sh. Non ho avuto tempo di indagare il problema. Usando la cupspatch-tahr64.pet CUPS funziona e sembra funzionare anche con la tua patch solo che con la tua patch la stampante laser non e' piu' rilevata. Appena ho tempo ci guardo.
Prova a togliere dalla patch 01 hplip 3.14.3 che tu chiami patch cups numero due: ho idea che sia quello il problema. In realta' sto usando un hplip 3.14.4 modificato da fatdog600 per le stampanti e scanner hp. In tahr64 funzionano i seguenti pet per stampanti e scanner hp

hplip_print_fd600-3.14.4-1.pet:

https://copy.com/aMhM1zemuymDuqAY

hplip_scan_fd600-3.14.4-1.pet:

https://copy.com/TAIRdctuDu9q610v
« Ultima modifica: Settembre 02, 2015, 08:34:43 am da watchdog »

Offline rapax

  • medio cagnulin
  • ***
  • Post: 190
  • Karma: +1/-0
  • Thar_Light_64bit - Linux User #469924
    • Mostra profilo
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #12 il: Settembre 01, 2015, 09:25:38 pm »
Salve a tutti,
PC usato per le prove ASUS X555LB, pdiag-20150901.tar.gz scaricabile da qui.
Queste le incongruenze riscontrate con Tahr-Media-64-k_4.1.3-EmSee_x86-64:
Mancano le seguenti icone:
   - pulsante "Avanzate" in "Puppy Network Wizard";
   - Menù -> Multimedia -> pMusic;
   - Menù -> Grafica -> PeasyGlue.

Non funzionano i seguenti applicativi:
   - Menu -> Sistema -> flSynclient (Vedi Screenshot)
   - Menu -> Sistema -> Pup-SysInfo -> Apps di sistema -> sys info (Lighthouse sistem info) NON visualizza alcun risultato;
   - Frisbee (non funziona probabilmente perchè manca la voce corrispondente in Bootmanager);
   - urxvtset (/usr/sbin/urxvtset: line 99: yad: command not found);
   - Pequalizer (Missing dependencies);
   - Cups (benchè con la Patch T_64-01 la situazione è migliorata, adesso riesco ad accedere a tutte le funzionalità)
     NON visualizza la mia Stampante nonostante il sistema la riconosca. ???

Output di "dmesg":
Codice: [Seleziona]
usb 1-1: new high-speed USB device number 7 using xhci_hcd
usb 1-1: New USB device found, idVendor=04e8, idProduct=3313
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: ML-1670 Series
usb 1-1: Manufacturer: Samsung Electronics Co., Ltd.
usb 1-1: SerialNumber: Z6ENBKFBA02447J.
usb 1-1: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
usb 1-1: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
usb 1-1: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
usb 1-1: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
usblp 1-1:1.0: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3313
udevd[28054]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1 1 7': No such file or directory
udevd[28048]: could not open builtin file '/lib/modules/4.1.3-EmSee-64/modules.builtin.bin'

Non funziona Pupdial:
Codice: [Seleziona]
--> WvDial: Internet dialer version 1.61
--> Warning: section [Dialer wireless] does not exist in wvdial.conf.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","tre.it"
AT+CGDCONT=1,"IP","tre.it"
OK
--> Modem initialized.
wvdial: utils/wvtask.cc:409: static void WvTaskMan::_stackmaster(): Assertion `magic_number == -0x123678' failed.
L'ultima riga non compare con le altre versioni di Puppy.

Si sente la mancanza di Quickpet e di un'icona firewall nella tray;
Errore di traduzione in Configurazione Retrovol -> Sliders Disbilitati (Disabilitati);
Per adesso e tutto. Work in progress.

Saluti rapax  :)

P.S. Posso usare file .sfs anche se non sono a 64 bit?
« Ultima modifica: Gennaio 22, 2016, 12:37:09 am da rapax »
Qui autem invenit illuminvenit thesaurum.

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 600
  • Karma: +3/-0
    • Mostra profilo
Re:Progetto Thar Media 64bit
« Risposta #13 il: Settembre 02, 2015, 07:46:08 am »
I files sfs installano programmi nel filesystem. Questi devono essere per forza 64 bit: ad esempio un sfs di libreoffice 32 bit non funzionerebbe. Puoi usare un chroot in un filesystem 32 bit per eseguire codice 32 bit da dentro tahr64-EmSee. Ma direi che la situazione e' del tutto sperimentale.

Offline xanad

  • Global Moderator
  • Pastore tedesco
  • *****
  • Post: 809
  • Karma: +3/-0
    • Mostra profilo
    • Puppy liveCD in italiano - Html5 Parallax
    • E-mail
Re:Progetto Thar Media 64bit
« Risposta #14 il: Settembre 02, 2015, 04:51:46 pm »
Patch 04 https://copy.com/vrypGxkaI60oTXiG
- eliminata vecchia installazione hlip
- eliminata voce menu pequalizer
-----
Ciao Rapax, ben tornato. Il progetto non ha nulla a che vedere con il Thar64 ufficiale che sta prendendo altre strade. Abbiamo aggiornato il kernel al 4.1.3 risolvendo molti problemi. Ora è una distro tutta italiana che seguirà la sua strada. Abbiamo apportato modifiche e migliorie al sistema originale che presentava molte lacune. Molti programmi inseriti dallo sviluppatore non sono a 64bit e piano piano stiamo cercando le soluzioni.

Citazione
Mancano le seguenti icone:
   - pulsante "Avanzate" in "Puppy Network Wizard"; -- non capiso dove
   - Menù -> Multimedia -> pMusic; -- risolto
   - Menù -> Grafica -> PeasyGlue. -- risolto

Non funzionano i seguenti applicativi:
   - Menu -> Sistema -> flSynclient (Vedi Screenshot) -- a me funziona, è solo per synaptic.
   - Menu -> Sistema -> Pup-SysInfo -> Apps di sistema -> sys info (Lighthouse sistem info) NON visualizza alcun risultato;--  da controllare
   - Frisbee (non funziona probabilmente perchè manca la voce corrispondente in Bootmanager); -- nessuna versione a 64bit, le altre distro lo hanno eliminato....
   - urxvtset (/usr/sbin/urxvtset: line 99: yad: command not found);
   - Pequalizer (Missing dependencies); -- idem come Fribee ma esiste un'alternativa che ho già preparato. Si può cercare anche in Ubuntu...
   - Cups (benchè con la Patch T_64-01 la situazione è migliorata, adesso riesco ad accedere a tutte le funzionalità)
     NON visualizza la mia Stampante nonostante il sistema la riconosca. -- lo specialista è Watchdog
Puppy liveCD in italiano - www.xanad.tk Html5 Parallax

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)

Dal blog internazionale

Tahrpup CE is Released

October 26, 2014 - Tahrpup 6.0 is released by 666philb in the Forum . Tahrpup uses Ubuntu 14.04 LTS Trusty Tahr packages and includes...

Leggi