Autore Topic: Puppy 5.3 Slacko  (Letto 6685 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline spartan3000_it

  • medio cagnulin
  • ***
  • Post: 106
  • Karma: +1/-0
    • Mostra profilo
    • E-mail
Puppy 5.3 Slacko
« il: Dicembre 06, 2011, 01:27:11 pm »
Ho voluto provare la nuova release che dovrebbe avere una compatibilita' binaria con i pacchetti di slackware anche se non sono esperto di questa distribuzione e non l'ho mai usata. Con Lupu 5.2x mi trovo bene e ho risolto tutti i problemi software per i programmi che uso. La slacko mi e' ostica. Gia' in partenza usando uno slackosave criptato c'e' un bug che fa saltare la backdrop image: bisogna dare da terminale
gdk-pixbuf-query-loaders --update-cache
per ripristinarla. Poi sono riuscito a far funzionare solo i fondamentali: posta con sylpheed e internet browsing con seamonkey 2.5. Il deb di peazip si installa e funziona, skype piu' webcam funzionano con l'ausilio delle librerie libv4l di cui funzionano le versioni debian-based, ma a parte questo non sono riuscito a far funzionare nessun programma per la visualizzazione della webcam (ho provato gucview, fswebcam, unicap, videoview, luvcview...), motion nell'ultima release non si compila e non si installa e neanche la versione pacchettizzata per slackware funziona perche' mancano diverse librerie, non si puo' usare il google_talkplugin perche' ne viene rilasciato solo un deb che non ha compatibilita' binaria con questa release. Secondo me c'e' ancora lavoro da fare con questa release.

Offline spartan3000_it

  • medio cagnulin
  • ***
  • Post: 106
  • Karma: +1/-0
    • Mostra profilo
    • E-mail
Re: Puppy 5.3 Slacko
« Risposta #1 il: Dicembre 19, 2011, 12:37:35 pm »
E' uscito Slacko 5.31 dove hanno risolto qualche bug tipo quello della backdrop image. Al seguente link:
http://208.109.22.214/puppy/viewtopic.php?p=584162&sid=59fc6c5044c91f2324e65da6f8be86fa
c'e' la soluzione per guvcview in slacko. Ho risolto il problema di motion (programma di videosorveglianza e gestione ffmpeg della webcam) scaricando il sorgente da git al seguente link:
http://www.lavrsen.dk/foswiki/bin/view/Motion/WebHome
e riuscendolo finalmente a compilare. Considero motion una alternativa a guvcview in generale per tutti i puppies. Facendo partire motion e aprendo il browser a localhost:8081 si puo' visualizzare la webcam e manipolando motion.conf si possono ottenere molte cose dalla propria webcam. L'unica cosa che non riesco ancora a far funzionare in slacko e che mi servirebbe e' il google-talkplugin. Al terminale l'errore e' indicato come "Inconsistency of ld.so...). Googlando anche altri hanno avuto il problema ma non ho trovato la soluzione. C'e' qualcuno in grado di aiutarmi?

Offline spartan3000_it

  • medio cagnulin
  • ***
  • Post: 106
  • Karma: +1/-0
    • Mostra profilo
    • E-mail
Re: Puppy 5.3 Slacko
« Risposta #2 il: Dicembre 26, 2011, 03:52:17 am »
Sono riuscito a caro prezzo a far funzionare il google-talkplugin su Slacko 5.31. Non sono esperto e sono solo uno smanettone quindi lascio agli esperti il compito di affinare la soluzione. In sostanza ho ricompilato Mesa-7.5.2 da ftp://ftp.freedesktop.org/pub/mesa/. Poi si puo' installare il deb del google-talkplugin e funziona. La controindicazione e' l'uso degli strumenti di compilazione e l'occupazione di spazio nel file di salvataggio, parecchia roba frutto della compilazione potrebbe essere suppongo cancellata. Qualcuno dovrebbe ricavarne un pacchetto in formato pet per usare la chat di google con questo puppy. Sempre che si sia interessati. La chat di google io la considero una alternativa a skype e skype-out (telefonare voip...) se qualcuno non dovesse gradire le vicende societarie che hanno visto skype cambiare proprieta'.

Offline puppylinux

  • Pastore tedesco
  • *****
  • Post: 1561
  • Karma: +9/-1
    • Mostra profilo
    • E-mail
Re: Puppy 5.3 Slacko
« Risposta #3 il: Dicembre 26, 2011, 04:03:49 am »
come saprai, al termine della compilazione, puoi dare, prima del make install

new2dir && make install

e puppy creerà tutto l'albero delle cartelle mettendoci dentro i file

alcuni programmi non si fanno però pacchettizzare da new2dir

in quel caso puoi provare:

make install DESTDIR=/percorsochevuoi

specificando una cartella all'interno della quale produrre tutto l'albero delle sottocartelle

talvolta però nemmeno questo comando funziona e si deve modificare il makefile fornito con il codice
http://dokupuppylinux.info
dropbox 2GB di spazio gratuito per i tuoi file - http://db.tt/Vc6IeN4
rimpiazza.co.cc con .info per accedere ai programmi linkati sul mio sito

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)