Autore Topic: Blocco sistema dopo sospensione [Risolto]  (Letto 1837 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline rapax

  • medio cagnulin
  • ***
  • Post: 218
  • Karma: +2/-0
  • Linux User #469924
    • Mostra profilo
    • E-mail
Blocco sistema dopo sospensione [Risolto]
« il: Febbraio 01, 2016, 09:17:16 pm »
Salve a tutti, ho acquistato una chiavetta USB 3.0 sulla quale ho installato (in modalità Full non Frugal) Quirky Werewolf64 7.4, che uso sul mio laptop Asus A555LB.
Il mio problema si manifesta quando riattivo il sistema dalla sospensione poichè si blocca tutto e sono costretto a spegnere in modo forzato (premendo il tasto d'alimentazione per più di 4 secondi).  :'( :'( :'(
Ho capito , almeno sul mio computer, che l'alimentazione delle porte USB viene interrotta quando il sistema è in sospensione e non è collegato alla rete elettrica (batteria in fase di scarica) se invvece è in fase di carica le porte USB rimangono alimentate e il problema, alla riattivazione, non si presenta.
Ho trovato molto su come disabilitare tale opzione su altri Sistemi Operativi ma il nostro cucciolo e diverso.  ;D
L'unica discussione trovata sul Forum Internazionale suggerisce di creare un file denominato usb.conf in /etc/modprobe.d e di inserirvi la seguente stringa "options usbcore.autosuspend=-1" se usbcore e integrato al kernel se invece viene caricato come modulo inserire la stringa "options usbcore autosuspend=0", ovviamente nessuna delle due ha funzionato.  :(
A corto di idee ma sopratutto ignorante in materia chiedo il vostro aiuto.
Ringrazio anticipatamente.  :)

rapax

EDIT: Ho cambiato il titolo del post perchè non rispecchiava l'effettivo problema.
« Ultima modifica: Febbraio 05, 2016, 08:18:49 pm da rapax »
Qui autem invenit illuminvenit thesaurum.

Offline rapax

  • medio cagnulin
  • ***
  • Post: 218
  • Karma: +2/-0
  • Linux User #469924
    • Mostra profilo
    • E-mail
Re:Sospensione selettiva porte USB
« Risposta #1 il: Febbraio 05, 2016, 08:11:36 pm »
Dopo qualche giorno di ricerche, prove e smanettamenti vari ho trovato una soluzione accettabile.
Vorrei per tanto condividere la mia esperienza. Inanzitutto il problema mi si è presentato solo per le versioni di puppy installate su periferiche usb (chiavette, hard disk, e probabilmente anche con carte SD ma non ho provato) in modalità full ma non per quelle installate in frugal, credo sia dovuto al diverso modo di funzionamento del cucciolo in base a come viene installato, come descritto da BK in how puppy works.
Per sospendere il sistema utilizzo lo script "suspend" presente nel pacchetto xbat-s.pet rilasciato da gjuhasz sul sito internazionale alla seguente discussione, la stringa che permette di sospendere il pc è la seguente "echo -n mem > /sys/power/state" ma poichè esistono diversi stati di sospensione, come descritto sul sito www.kernel.org , ho provato la seguente stringa "echo -n freeze > /sys/power/state" e alla riattivazione il sistema ha funzionato regolarmente, anche in fase di scarica della batteria, di contro ho un minor risparmio energetico in fase di sospensione.
Per sapere gli stati di sospensione supportate dal proprio sistema digitate in un terminale il seguente comando:
Codice: [Seleziona]
cat /sys/power/state
rapax
Qui autem invenit illuminvenit thesaurum.

Offline Ash

  • medio cagnulin
  • ***
  • Post: 132
  • Karma: +1/-0
  • Woof Woof!
    • Mostra profilo
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #2 il: Febbraio 08, 2016, 08:45:07 am »
Ottimo!
Grazie per aver condiviso la tua esperienza con noi.
Anch'io ho installato puppy su una chiavetta Usb ma almeno sul mio portatile,quando abbasso il coperchio va in stand-by ma appena lo rialzo parte tutto alla perfezione senza nessun problema.
Se dovesse presentarsi il problema su un'altro terminale ora saprei cosa fare ;)
...Puppy Addicted...
Fare del bene porta altro bene....

Offline rapax

  • medio cagnulin
  • ***
  • Post: 218
  • Karma: +2/-0
  • Linux User #469924
    • Mostra profilo
    • E-mail
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #3 il: Febbraio 08, 2016, 09:29:26 pm »
Grazie Ash, è sempre un piacere poter essere d'aiuto a qualcuno.

Anch'io ho installato puppy su una chiavetta Usb ma almeno sul mio portatile,quando abbasso il coperchio va in stand-by ma appena lo rialzo parte tutto alla perfezione senza nessun problema.

Onestamente non avevo provato a vedere cosa succede abbassando il coperchio del portatile, non è nelle mie abitudini farlo, ma dopo aver letto il tuo post l'ho fatto ora mi attendono giorni di ricerche, prove e smanettamenti vari.  ;D

Saluti.
Qui autem invenit illuminvenit thesaurum.

Offline Ash

  • medio cagnulin
  • ***
  • Post: 132
  • Karma: +1/-0
  • Woof Woof!
    • Mostra profilo
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #4 il: Febbraio 09, 2016, 08:37:00 am »
Ottimo!Facci sapere il tuo risultato allora ;)
Ciao
...Puppy Addicted...
Fare del bene porta altro bene....

Offline rapax

  • medio cagnulin
  • ***
  • Post: 218
  • Karma: +2/-0
  • Linux User #469924
    • Mostra profilo
    • E-mail
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #5 il: Febbraio 10, 2016, 12:26:32 am »
Chiedo scusa Ash ma credo di essere stato troppo frettoloso, effettuando ulteriori prove non ho più avuto problemi di blocco del sistema nel chiudere e riaprire il coperchio del portatile, meglio così. L'unico inconveniente è che quando sollevo il coperchio il sitema si riattiva per un istante poi ritorna in sospensione e devo premere un tasto qualsiasi per riattivarlo  ??? , succede anche a te? 
« Ultima modifica: Febbraio 10, 2016, 12:29:33 am da rapax »
Qui autem invenit illuminvenit thesaurum.

Offline Ash

  • medio cagnulin
  • ***
  • Post: 132
  • Karma: +1/-0
  • Woof Woof!
    • Mostra profilo
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #6 il: Febbraio 10, 2016, 09:27:27 am »
No nel mio pc appena alzo il coperchio si attiva tutto in modo normale.E onestamente non ho settato nulla di particolare per farglielo fare.Ieri però senza toccare nulla e dall'oggi al domani non mi funzionano più i tasti funzione.Mentre con l'altra distro installata funziona tutto tranquillamente...boh devo indagare...
...Puppy Addicted...
Fare del bene porta altro bene....

Offline rapax

  • medio cagnulin
  • ***
  • Post: 218
  • Karma: +2/-0
  • Linux User #469924
    • Mostra profilo
    • E-mail
Re:Blocco sistema dopo sospensione [Risolto]
« Risposta #7 il: Febbraio 10, 2016, 09:55:29 pm »
I tasti funzione è un'altra di quelle cose che non ho l'abitudine di usare, se può interessarti a me non hanno mai funzionato con nessuna delle versioni di puppy che ho provato, sul forum internazionale si parla di usare tool tipo xbindkeys o xdotool, ma credo che questo tu lo sappia già.  :)
Qui autem invenit illuminvenit thesaurum.

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)