Autore Topic: Puppy 4.31 rewind  (Letto 1006 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 683
  • Karma: +6/-0
    • Mostra profilo
Puppy 4.31 rewind
« il: Dicembre 18, 2016, 04:07:44 pm »
Ho masterizzato la mia puppy 4.31 che mi sta dando soddisfazioni sulle mie macchine un po' vecchiotte. Non e' in italiano e non e' perfetta ma qualche amatore potrebbe trovarla utile.

custom-puppy-pup-431.iso:

https://drive.google.com/file/d/0B9iMb4UZBeFkTXdhalBGVm9uWEU/view?usp=sharing

Segnalo il browser palemoon 27.0.2 e firefox 38.8.8 ESR. Ecco la lista completa della dotazione:

bash-3.0.22-i486|bash|3.0.22-i486||BuildingBlock|1604K||bash-3.0.22-i486.pet||bash 3.0.22|puppy|wary5||
debbi-1.1|debbi|1.1||BuildingBlock|20K||debbi-1.1.pet||Brother printer installer||||
gtk+-2.18.3-p4|gtk+|2.18.3-p4||BuildingBlock|6556K|pet_packages-4|gtk+-2.18.3-p4.pet|+pcre,+atk,+glib,+pixman,+pango,+cairo|gui widget library|puppy|4|official|
gtk+_DEV-2.18.3-p4|gtk+_DEV|2.18.3-p4||BuildingBlock|2344K|pet_packages-4|gtk+_DEV-2.18.3-p4.pet|+gtk+|gui widget library|puppy|4|official|
gtkdialog4-0.8.3-i486|gtkdialog4|0.8.3-i486||BuildingBlock|276K||gtkdialog4-0.8.3-i486.pet|+gtk+|gui for shell scripts|puppy|wary5||
libdbus-1-3_1.2.1|libdbus-1-3|1.2.1|5+lenny1||||libdbus-1-3_1.2.1-5+lenny1_i386.deb|||
libdbus-glib|libdbus-glib-1-2|libdbus-glib|1||||libdbus-glib-1-2_0.76-1_i386.deb|||
libnetsnmp-15-mu-p4|libnetsnmp|15-mu-p4||BuildingBlock|532K|pet_packages-4|libnetsnmp-15-mu-p4.pet||needed by hpliplite, hp printing|puppy|4|official|
motion-3.2.12-i486|motion|3.2.12-i486||BuildingBlock|972K|pet_packages-4|motion-3.2.12-i486.pet||motion|puppy|4|official|
mtoolspassaggio|mtoolspassaggio|||BuildingBlock|1076K||mtoolspassaggio.pet||no description provided|ubuntu|lucid||
hpliplite-3.9.8-mu-p4|hpliplite|3.9.8-mu-p4||Setup|8720K|pet_packages-4|hpliplite-3.9.8-mu-p4.pet|+libnetsnmp,+gutenprint,+cups,+ghostscript,+foomatic-filters|Hewlett Packard printer and scanner drivers|puppy|4|official|
hpijs-2.8.2_static-1|hpijs|2.8.2_static-1||Setup|4104K|pet_packages-4|hpijs-2.8.2_static-1.pet|+cups|drivers for hewlett packard printers|
p7zip-full|p7zip|full||BuildingBlock|3412K||p7zip-full.pet||no description provided|ubuntu|lucid||
psip-0.26|psip|0.26||Internet|1416K||psip-0.26.pet||Psip Puppy Phone|ubuntu|lucid||
qt-3.3.8|qt|3.3.8||BuildingBlock|7596K|pet_packages-3|qt-3.3.8.pet||a multi-platform C++ graphical user interface toolkit|
retrovol-0.13.1|retrovol|0.13.1|||||retrovol-0.13.1.pet|||
sfs_load-1.9.6|sfs_load|1.9.6||Setup|196K||sfs_load-1.9.6.pet||Load Squash files||||
v4l2ucp_1.2-0.1_i386|v4l2ucp_1.2|0.1_i386|||||v4l2ucp_1.2-0.1_i386.pet|||
v4l-utils-1.0.1-i486|v4l-utils|1.0.1-i486||BuildingBlock|3020K||v4l-utils-1.0.1-i486.pet||Video4Linux utils|puppy|wary5||
wget-1.16-i486|wget|1.16-i486||BuildingBlock|2256K|pet_packages-4|wget-1.16-i486.pet||wget|puppy|4|official|
UExtract-uextract-3.25|UExtract|uextract-3.25||Utility|296K||uextract-3.25.pet||Ultimate Extractor||||
cursor_themes-1-1|cursor_themes|1-1||Desktop|41276K||cursor_themes-1-1.pet||themes for mouse cursor||||
audacity-static-1.3.12|audacity-static|1.3.12||Multimedia|11856K||audacity-static-1.3.12.pet||Record and edit audio files|ubuntu|raring||
jwm-657-p431|jwm|657-p431|||||jwm-657-p431.pet|||
geany-0.18-p4|geany|0.18-p4||Document|2048K|pet_packages-4|geany-0.18-p4.pet|+gtk+|Geany superb text editor|puppy|4|official|
glib-2.22.2-p4|glib|2.22.2-p4||BuildingBlock|1756K|pet_packages-4|glib-2.22.2-p4.pet|+pcre|system library|puppy|4|official|
firewall_ng-p4|firewall_ng|p4||Network|64K|pet_packages-4|firewall_ng-p4.pet||Firewall Setup|puppy|4|official|
openssl_DEV-1.0.2j-p4-i486|openssl_DEV|1.0.2j-p4-i486||BuildingBlock|5080K|pet_packages-4|openssl_DEV-1.0.2j-p4-i486.pet||openssl|puppy|4|official|
openssl-1.0.2j-p4-i486|openssl|1.0.2j-p4-i486||BuildingBlock|3092K|pet_packages-4|openssl-1.0.2j-p4-i486.pet||openssl|puppy|4|official|
pfs-master-git-1-i486|pfs-master-git|1-i486||BuildingBlock|72K|pet_packages-4|pfs-master-git-1-i486.pet||pcloud|puppy|4|official|
firefox-38.8.8esr-p4-it-glibc219tweak|firefox|38.8.8esr-p4-it-glibc219tweak||Internet|112916K|pet_packages-4|firefox-38.8.8esr-p4-it-glibc219tweak.pet||Firefox web browser|puppy|4|official|
ytdlgui|ytdlgui|||Internet|772K||ytdlgui.pet||youtube-dl gui||||
palemoon-27.0.2-p4-glibc219tweak|palemoon|27.0.2-p4-glibc219tweak||Internet|121880K||palemoon-27.0.2-p4-glibc219tweak.pet||Palemoon web browser|puppy|puppy4||
sgmixer-0.3|sgmixer|0.3||Multimedia|40K|pet_packages-4|sgmixer-0.3.pet|+gtk+,+alsa-lib|audio mixer|

Ha inoltre unetbootin da usare da terminale in /usr/bin. Youtube-dl. Pfs-master-git e' il client di Pcloud che ha la cartella condivisa in /root (dove salva le immagini anche motion) e che si lancia con:

Codice: [Seleziona]
mount.pfs --username xxxxxxx --password yyyyyyyy pCloud
In /usr/sbin ci sono due versioni di filemnt: quella in uso e' in grado di monatre savefiles criptati mentre quello originale monta gli sfs. Basta rinominarli ad esigenza.
Se qualcuno vuole provare questo remaster essendo un amatore di puppy 4.31 per i pc vecchi sono sicuro che almeno avra' delle idee per personalizzare il suo puppy 4.31. Se volete aggiornare palemoon andate a:

http://www.murga-linux.com/puppy/viewtopic.php?p=933443#933443

Offline danielozma

  • medio cagnulin
  • ***
  • Post: 179
  • Karma: +0/-0
    • Mostra profilo
Re:Puppy 4.31 rewind
« Risposta #1 il: Dicembre 18, 2016, 10:50:43 pm »
Se la organizzi con grafica sua, manuale (anche copiando dalle mie realizzazioni, se vuoi) ed almeno una pagina web di descrizione sarei ben lieto di pubblicizzare questa opera dal mio sito.
Buona serata.

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 683
  • Karma: +6/-0
    • Mostra profilo
Re:Puppy 4.31 rewind
« Risposta #2 il: Dicembre 19, 2016, 08:11:01 am »
Direi che non e' il caso di spendere altro tempo: siamo in 4 gatti e rispondo solo a richieste specifiche. Dimenticavo di dire che c'e' libreoffice 3.3 portable a cui va aggiunto un dizionario in italiano. Ci ho lasciato qt-4.7.1 perche' per puppy4 e' quasi introvabile. Il devx e' compreso nel remaster. Per compilare drivers specifici occorre il kernel-sources da scaricare dai repository ufficiali. Buona giornata.

Offline Player One

  • grande cagnulin
  • ****
  • Post: 309
  • Karma: +0/-0
  • XenialPUP 7.5 su IBM Thinkpad R40
    • Mostra profilo
    • E-mail
Re:Puppy 4.31 rewind
« Risposta #3 il: Dicembre 19, 2016, 10:24:28 am »
Grazie, tornerà utile sicuramente :)

Offline ichnos

  • cucciolo
  • *
  • Post: 1
  • Karma: +0/-0
    • Mostra profilo
Re:Puppy 4.31 rewind
« Risposta #4 il: Dicembre 20, 2016, 11:34:25 pm »
L'ho provata in cd/dvd live su un portatile quindicenne ( Pentium 4 mobile, 1.80GHz, 1 Gb ram), reduce dalle guerre ma invitto, e va molto bene. Oltre ad Archlinux con Lxde e Openbox, installata su hd, è stata l'unica delle tante distro provate a placare la ventola, sempre al massimo. Funzionano meglio anche chiusura e spegnimento, che finora sono stati puntuali, anche al salvataggio della sessione sullo stesso dvd ( so che è sconsigliato, l'ho fatto solo per mia curiosità, e per evitare i passaggi iniziali di configurazione).  Per la connessione wireless con un adapter usb netgear mi carica ndiswrapper ma poi non trova nessuna rete: devo dire però che ho forti dubbi sullo stato dell'hardware, perché neanche con tahr 6.0 trova più niente, e nemmeno con arch.
Come tu stesso hai chiarito, e se ho capito, essendo abbastanza datata, l'hai resa disponibile  più per una specie di interesse o curiosità storici, insomma per un uso sperimentale, che per eventuali usi comuni ( evidentemente rari o improbabili) ma, malgrado la mia ampia incompetenza, mi sembra molto ben fatta e quel Libroffice portable mi risulta piuttosto originale e sorprendente.
Ho seguito volta per volta il lavoro straordinario che tu, xanad e altri avete svolto per la tahr, da qualche parte avevo letto di una tua versione portable di firefox, e stavo quasi per chiedere qui su qualcosa di simile per libreoffice. Ora colgo l'occasione di averla trovata dentro la custom-puppy-pup-431 per chiedere:

- è possibile avere qualche informazione in più su come è stata costruita questa versione?  Ho visto che oltre all'eseguibile in /usr/bin, al file desktop e al pixmap dello start, sono tutti file in python. Finora, guardando dentro i file sfs di libreoffice per Puppy, o in quelli squashfs delle Orbital Apps, o ancora dentro le AppImages e le Snap, avevo trovato altri tipi di strutture, benché analoghe. In che senso, fino a che punto è una versione portable? Soltanto nell'ambito di questa puppy o anche usabile da altri luoghi, per es. da una semplice penna usb? Non sarebbe possibile farne una versione più recente, magari in italiano?

p.s. avevo scritto un post per aprire una nuova discussione su questo argomento ( libreoffice portable), ma è venuto davvero troppo lungo, non me la sentivo di pubblicarlo in quella forma, e così ho approfittato per chiedere qui, stringando le domande. Da principiante mi accontenterei di poche indicazioni utili a capire meglio la situazione. Ringrazio in ogni caso, e vi faccio i migliori auguri!!

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 683
  • Karma: +6/-0
    • Mostra profilo
Re:Puppy 4.31 rewind
« Risposta #5 il: Dicembre 21, 2016, 06:39:16 am »
Il libreoffice 3.3 portable e' pre so dal seguente repository di pacchetti portable (scorri in fondo):

https://sourceforge.net/projects/portable/files/

Ci ho aggiunto al binario messo in /usr/bin solo il desktop file in usr/share/applications e un'icona generica in /usr/share/pixmaps. Occorre un java un po' vecchio e ci ho messo un pacchetto sfs che e' andato nel remaster di jre-1.6u45-i586.sfs scaricato dal forum internazionale. Il pacchetto jre lo puoi cercare con un motore di ricerca specifico per puppy:

http://wellminded.net63.net/

Se vuoi un libreoffice in italiano puoi usare la 3.6.3 che e' ancora disponibile:

http://www.italianpuppy.org/community/index.php?topic=1144.0

Anche se ho testato funzionante in puppy4 libreoffice fino alla almeno 4.0.1 che se ti serve posso mettere a disposizione (in italiano). Tieni presente che il plugin java per il browser e' in disuso (io non lo installo piu') e quindi per far funzionare libreoffice basta anche un vecchio pacchetto java "scaduto".

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)