Autore Topic: Installazione full non riuscita  (Letto 254 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Installazione full non riuscita
« il: Dicembre 30, 2018, 12:15:19 am »
Salve, sto cercando di installare Puppy sul mio Asus eee704, ma ho un problema. Ho masterizzato l'immagine iso sul cd e da lettore esterno ho avviato la live. Da qui ho fatto l'istallazione full, ho installato il grub, ho salvato i settaggi, ma al momento di partire ho un messaggio di errore, vi allego la foto della schermata di avvio. Mi date una mano?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #1 il: Dicembre 30, 2018, 05:44:25 am »
Da quello che vedo probabilmente hai il menu.lst non corretto per l'installazione full: sta cercando una installazione frugale che non trova. Io non sono esperto della installazione full ma prova ad accedere al tuo menu.lst sull'asus e posta qui il contenuto. Dovresti modificarlo per l'installazione full.

EDIT: per l'installazione full il contenuto di menu.lst deve essere del tipo:

Codice: [Seleziona]
title Puppy full (on /dev/sda1)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal
« Ultima modifica: Dicembre 30, 2018, 12:15:25 pm da watchdog »

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #2 il: Gennaio 16, 2019, 01:14:39 am »
Salve, scusate per l'assenza. Ecco il mio file Menù.lst

Codice: [Seleziona]
# menu.lst produced by grub4dosconfig-v1.9.2
color white/blue black/cyan white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0
# Full installed Linux
title Xenialpup 7.5 (sda1/boot)
uuid 11ce22a9-24fe-45d7-9371-a003f13eeba4
kernel /boot/vmlinuz root=/dev/sda1
initrd /boot/initrd.gz
title Xenialpup 7.5 (sda1/boot)
uuid 11ce22a9-24fe-45d7-9371-a003f13eeba4
kernel /boot/vmlinuz root=/dev/sda1
initrd /boot/initrd.gz
# Windows
# Advanced Menu
title Advanced menu
configfile /menu-advanced.lst
commandline

Cosa c'è di sbagliato?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #3 il: Gennaio 16, 2019, 04:18:39 am »
Se hai fatto la installazione full, che non e' il modo normale di installazione di puppy ed e' usata pochissimo, secondo me devi modificare il menu.lst in questo modo:

Codice: [Seleziona]
# menu.lst produced by grub4dosconfig-v1.9.2
color white/blue black/cyan white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0
# Full installed Linux
title Xenialpup 7.5 (sda1/boot)
uuid 11ce22a9-24fe-45d7-9371-a003f13eeba4
kernel /boot/vmlinuz root=/dev/sda1 ro
#initrd /boot/initrd.gz
# Windows
# Advanced Menu
title Advanced menu
configfile /menu-advanced.lst
commandline

Io comunque farei una installazione frugale. In rete ci sono molti tutorial anche su questo sito immagino.

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #4 il: Gennaio 16, 2019, 07:10:07 pm »
Grazie della risposta, ma non vorrei fare l'installazione frugale per non dover portarmi dietro il lettore dvd esterno e il disco, visto che il portatile lo porto sempre con me in borsa. Altrimenti sarei costretto a cercare un'altra distribuzione in grado di stare nei 4gb di hd. Se facessi l'installazione sulla scheda sd la situazione migliorerebbe oppure sarebbe la stessa?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #5 il: Gennaio 16, 2019, 08:11:52 pm »
Puoi fare una installazione frugale senza dover usare ogni volta il dvd per il boot. E' molto semplice. Crea una cartella alla radice di una partizione e dentro ci metti tutti i file della iso di puppy che intendi utilizzare. La iso la monti semplicemente cliccandoci sopra con una sessione live di puppy. Poi lancia Grub4dos bootloader config che crea il bootloader per caricare la tua installazione frugale all'avvio da hard disk.

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #6 il: Gennaio 16, 2019, 09:14:32 pm »
Ok, allora potrei provare così. Ho ancora la SD con tutti i file della iso, la inserisco e la faccio partire da lì in live, poi rifaccio l’installazione ma scelgo la Frugale, poi lancio il Grub4dos e scelgo di salvare la configurazione su hard disk  o su SD ?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #7 il: Gennaio 17, 2019, 06:07:57 am »
Se scegli di installare grub4dos su hd il savefile sara' su hd. La cartella con i files della iso la devi mettere su hd. Copia i files della iso in una cartella su hd.

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #8 il: Febbraio 02, 2019, 01:29:34 am »
Ho fatto come da tuo suggerimento e il Pc parte, però non mi ha caricato la scheda Wi-Fi! Tramite scheda esterna riesco a navigare, come devo fare per fargli riconoscere la mia scheda Wi-Fi interna?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #9 il: Febbraio 02, 2019, 05:11:31 am »
Io spero che sia solo un problema di firmware per il tuo wireless. Altrimenti la faccenda si fa piu' complicata. Se e' solo il firmware prova a fare cosi'. Scarica:

http://www.fishprogs.software/puppy/firmware-sfs/linux_firmware_20190124.sfs

Rinomina il file sfs come fdrv_xenialpup_7.5.sfs e copialo nella cartella dove sono tutti i files della tua installazione frugale. Fai il reboot e vedi se adesso il tuo wireless funziona.

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #10 il: Febbraio 06, 2019, 11:26:57 am »
Grazie del suggerimento, ho scaricato il file ma non riesco a inserirlo nella scheda SD, nelle proprietà risulta che non c'è spazio, nonostante la scheda sia da 8 Gb e lo spazio utilizzato sia solo 340 Mb. Quando inserisco la scheda per montarla viene riconosciuta come CDROM, è normale?

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 706
  • Karma: +6/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #11 il: Febbraio 06, 2019, 01:14:19 pm »
Non e' normale che una scheda SD venga riconosciuta come Cdrom. Non riesco ad immaginare come sia possibile. Se hai creato un savefile su SD e lo stai usando la scheda SD e il suo contenuto lo dovresti vedere in /mnt/home.  Comunque rileggi la discussione dall'inizio. Ti ho gia' dato delle indicazioni su come fare una installazione frugale sull'hard disk principale del tuo pc. Fai l'installazione frugale su hd e installa grub4dos che e' il modo normale di installare puppy.

Offline Player One

  • Global Moderator
  • grande cagnulin
  • *****
  • Post: 314
  • Karma: +0/-0
  • XenialPUP 7.5 su IBM Thinkpad R40
    • Mostra profilo
    • E-mail
Re:Installazione full non riuscita
« Risposta #12 il: Febbraio 06, 2019, 03:21:17 pm »
Aggiungo qualche info utile
  • prima dell'installazione frugale sarebbe meglio formattare la scheda sd  in ext4 con gparted, così quando andrai a salvare la sessione per la prima volta ti creerà una save folder (che può sfruttare tutto lo spazio sulla partizione) invece di un savefile (che ha spazio limitato)
  • il fatto che venga riconosciuta come cd rom da cosa lo deduci? Se è solo per l'icona sul desktop è normale, anche a me mette l'icona del CD su tutte le unità esterne

Offline Massimiliano

  • cucciolo
  • *
  • Post: 10
  • Karma: +0/-0
    • Mostra profilo
Re:Installazione full non riuscita
« Risposta #13 il: Febbraio 06, 2019, 09:32:36 pm »
Ecco, penso di aver fatto qualche errore. La scheda SD viene vista come CD-ROM se la monto su un altro Pc. Per fare prima ho scaricato il file da un altro Pc e volevo copiarlo sulla SD, ma non me lo fa fare. Per copiarlo su hd interno ce lo passo con la chiave usb oppure lo scarico direttamente. Giusto? Riguardo la procedura di installazione frugale credo di averla fatta giusta, ma stasera la riguardo meglio, però a funzionare funziona bene!

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)