Autore Topic: Glibc upgrade di wary 5.5 x pc vecchi (in inglese)  (Letto 640 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline watchdog

  • Pastore tedesco
  • *****
  • Post: 683
  • Karma: +6/-0
    • Mostra profilo
Glibc upgrade di wary 5.5 x pc vecchi (in inglese)
« il: Marzo 13, 2016, 09:34:30 am »
Per facilitare il glibc upgrade di wary 5.5 per computer vecchi in modo che si possono utilizzare anche i softwares moderni ho fatto l'upload di un puppy_wary_5.5.sfs (sfs principale di wary) modificato con il glibc di lucid. Il glibc upgrade rovina un po' la localizzazione per cui si potra' usare in inglese almeno per la maggior parte dei programmi. Scaricate l'sfs e utilizzatelo al posto di quello dell'iso ufficiale in:

http://distro.ibiblio.org/quirky/wary-5.5/

puppy_wary_5.5.sfs-md5:

4c12c194eeda842165fd47ab43717c0d

puppy_wary_5.5.sfs:

https://drive.google.com/file/d/0B9iMb4UZBeFkWmxCX3ZvS3JhNFE/view?usp=sharing

Dopo il primo avvio anche con un pupsave gia' precedentemente creato aprite con geany /etc/profile e modificatelo nel seguente modo alle righe corrispondenti:

Codice: [Seleziona]
#this line gets edited by chooselocale script...
# w004 going back to non-utf8... 101120 back to utf8... 101121 off again...
#110409 change .utf8 to .UTF-8 ...
#LANG=en_US.UTF-8
LANG=it_IT.UTF-8
export LANG

#v426 recommended by MU, avoid crashing for non-English locales on some apps...
#120525 shinobar: don't think we need this...
#export LC_COLLATE=en_US
export LC_ALL=C

A me funziona. Per controllare la versione di glibc digitate nel terminale:

Codice: [Seleziona]
/lib/libc.so.6
Codice: [Seleziona]
# /lib/libc.so.6
GNU C Library (Ubuntu EGLIBC 2.11.1-0ubuntu7.21) stable release version 2.11.1, by Roland McGrath et al.
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 4.4.3.
Compiled on a Linux >>3.2.0-75-generic<< system on 2015-02-25.
Available extensions:
crypt add-on version 2.1 by Michael Glad and others
GNU Libidn by Simon Josefsson
Native POSIX Threads Library by Ulrich Drepper et al
BIND-8.2.3-T5B
For bug reporting instructions, please see:
<http://www.debian.org/Bugs/>.

Di rigore aggiornare anche openssl:

http://www.murga-linux.com/puppy/viewtopic.php?p=891788#891788

Consiglio di usare opendns perche' il glibc di lucid non e' patchato con l'ultimo bug. Mettete in /etc un file revolv.conf.head col seguente contenuto:

Codice: [Seleziona]
nameserver 208.67.222.222
nameserver 208.67.220.220

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)