Autore Topic: Problema generico delle Pupplets  (Letto 3873 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline pepeyomat

  • cagnulin
  • **
  • Post: 80
    • Mostra profilo
Problema generico delle Pupplets
« il: Giugno 01, 2010, 07:59:18 pm »
Ciao a tutti,
ho riscontrato questo problema che non riescoa risolvere ed è molto fastidioso...

Puppy occupa più o meno 100 Mb e ha una impostazione che gli dice se può o non può caricarsi totalmente in ram!!
Questa impostazione si chiama ramdisk_size e fa in modo che se il sistema sappia quanta ram verrà occupata dal sistema una volta caricato....
Se iene creata una pupplets di grosse dimensioni il parametro resta lo stesso e può capitare che il sistema pensi di riuscire a scompattarsi totalmente in ram e invece non ci stà.... risultato kernel panic!!!
Questa impostazione (in teoria potrebbe essere modificata al boot con l'opzione puppy ramdisk_size=xxxxxxx (in Kb) però ho provato a mettere la dimensione della mia ram e non va lo stesso.
Ho trovato questo link:
http://pupweb.org/wikka/BootParms?show_comments=1
in cui c'è scritto che "The kernel is configured with a 12288KB maximum ramdisk"!?!?!?!
Come è possibile... sono 12Mb?????
di Default??
Qualcuno sa spiegarmi questa cosa???
Ciao
Grazie!

Offline elpablo75

  • grande cagnulin
  • ****
  • Post: 459
    • Mostra profilo
Re: Problema generico delle Pupplets
« Risposta #1 il: Giugno 18, 2010, 11:52:14 am »
Interessante l'opzione ramdisk_size.
Io vorrei provare una cosa un pò diversa. In pratica lanciare puppy sul pc desktop senza caricarlo in ram, lasciando la ram solo alle applicazioni che uso davvero in quel momento.
Senza aprire nessuna applicazione, puppy mi occupa 61MB, con connessione lan e glipper attivi, non so cos'altro.
Essendo però un utilizzatore convinto di Opera devo fare i conti con un consumo non indifferente di risorse, quindi più riesco a recuperarne e meglio è. L'hardware del pc desktop è un pò datato,
HD Samsung SV1021H (10GB), P3 866MHz e 256MB di ram condivisa, il video ne ha 16 assegnati da bios.
Aprendo opera ho questo risultato:

Tra l'altro tre processi di opera uguali identici, perchè? E arrivo facilmente a 190MB usati senza aprire altro che opera.

Se metto ramdisk_size=0 equivale al pfix=noram che si usa sui cdlive oppure non c'entra niente e faccio un disastro ed è meglio tenermelo così?

 

Iscriviti alla newsletter

Ricevi le notizie più importanti direttamente nella tua casella email (premi invio dopo l'indirizzo)